trying to get h.264 and aac to encode [solved]

I came to believe the only way to get rendering with h.264 avc and aac to work on my ubuntu 10.4 was by following the instructions at ubuntu forum: http://ubuntuforums.org/showpost.php?p=9868359&postcount=1289, and so I did that. I still get grayed (pinked) out x264 options for rendering. However, if I choose "transcode", and had copied the settings from the render preset, it definitely tries to transcode with x264 and aac, but somehow the parameters are wrong because 2-pass doesn't work (something about the pass file having a problem), and also it gets an error about parameter such as height, width, etc being wrong. But it creates a file called "/f=mp4". If I get rid if that parameter it creates a file calle "/hq=1", and so on down the line. Always the first parameter is used to create a file with that parameter as the filename. I took these parameters and tried to use them in command line and got these errors.

So I saw in one of the posts here where a Mr. Kennedy says that if you re-do ffmpeg, etc from source then you need to also do MLT. And so I found this forum's topic http://www.kdenlive.org/forum/howto-install-kdenlive-melt-faad-faac-x264... for ubuntu 9.10. I need the same instructions but for ubuntu 10.4. Will those instructions work for 10.4?

So there's a few things I'm asking: will aforementioned post be OK for ubuntu 10.4? Why does transcode at least TRY to use x264 / aac where render has it grayed (pinked) out? Why don't the preset parameters that I copied from render give good syntax to be used for transcode? Why, when I translate these parameters into command-line format do I get the errors? (I took the format that says f=mp4.......etc) and changed it to -f mp4.....etc)

I know I'm in the "installing from source" forum; that is because I found a very relevant thread to refer to in this same forum. But ultimately I want to be able to render to H.264 AVC/AAC MP4 file. Alrighty everyone, have a look and please see who has the answers. Thanks! :)

BTW, using ffmpeg command line to transcode works, so I know X264 and aac work. I took a small indeo 3 avi file and converted it to 1280x720 60 FPS H.264 AVC / AAC file. I am trying to compile kdenlive source as per previously mentioned posted guide. I'm hung up in the MLT part of it because there is a compile error. I posted a separate entry for that.

I got it to work. I simply updated a file called kdenliverc and made sure the aac and libfaac codecs were in there. Go to terminal and enter "locate kdenliverc" to find it.