ubuntu 11.10 won't run kdenlive ("MLT's SDL module not found")

Greetings -

I updated to ubuntu 11.10 and now kdenlive won't run. Kicks out an Fatal error "MLT's SDL module not found".

This error seems common but I'm not finding the fix. Any thoughts appreciated.

thx

Reid

There are basically (at least) two workarounds available -- both not ideal, yet at least the ppa should work the easiest way:
1) add ppa:sunab/kdenlive-svn to your repository source, update, install. However, be aware that this is a testing repository so things may break (see also: https://launchpad.net/~sunab/+archive/kdenlive-svn). However, I had no problems with the latest two or three versions pushed to this repository. The repository both supplies you with kdenlive as well as mlt. For me, this was the easiest way to get kdenlive fly on my Kubuntu 11.10 and work on my first two (dive) videos.
2) grab the sources and compile them yourself. This is the heavy-handed last resort and will cause most probably a lot of grief. So I advise to go with option 1).

Thank you for your reply!! I'm pretty new at this, can you give me further help?
How do I go about: 1) add ppa:sunab/kdenlive-svn to your repository source, update, install.

Thank you very much!

sudo add-apt-repository ppa:sunab/kdenlive-svn

Thanks Dive0. worked like a champ (for now I guess :-> ). I've not had trouble from these kind of development sources before but I understand the warning. Where are the standard sources, and WHY are those broken...? Perhaps it's just the new Ubuntu release?

pasajero7: in your System Settings->System you will find an icon for Software Sources. When opened you will then go to the Other Software tab. Select Add and paste the link Dive0 posted. Then you need Ubuntu to reload these pointers (wrong nomenclature but you get the idea). I do that through Synaptic. (for some silly reason the developers removed that great tool). Use this at the command-line to pull it: sudo apt-get install synaptic.
In the upper left corner you will see a "reload" button and it will refresh your sources. Then just check for updates it it will pull the packages you need.

rsv869

Thank you rsv869! I was doing find until the: "Use this at the command-line to pull it: sudo apt-get install synaptic.
In the upper left corner you will see a "reload" button and it will refresh your sources. Then just check for updates it it will pull the packages you need.

I'm using Kubuntu and mainly the muon package manager to add and remove package repositories, thus I'm afraid I'm of no help here. Apart from the muon package manager I use aptitude from the console, as this is also often more hassle-free, but it cannot manage repositories.

It would be nice to add kdenlive-release for oneiric in the PPA (SVN should be too much unstable)

Hi,

I just installed Ubuntu 11.10 with Wubi, installed kdenlive and also have "MLT's SDL not found" error. Can someone tell me how to fix this in Wubi install?

I'm new at this so help is appreciated :-)

As far as I know it doesn't matter in your case whether this is a wubi install or the usual CD/USB installation. Please follow the steps as mentioned above: either add the kdenlive-svn repository as described above if you want to try the latest version. Otherwise, add the kdenlive-release repository. You find an installation description here: http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-..., see the Ubuntu packages section on this page.

If you add ppa:sunab/kdenlive-svn instead, then you will get the most recent development version. This may or may not be better; I had almost no trouble with the svn version thus I'm currently going with it as it has the backup feature added.

Hi DiveO

Thanks for your help. I was able to install the kdenlive-release repository successfully. However, although it opens without the MLT error, it takes me through the initial config wizard, then after clicking "finish" on the "checking system" window, it disappears.

Would the svn version solve this problem??

Thank you so much for this advice. Now I have another problem, how to get coodeks to H.264-format?

EDIT: This was solved by the finnish list:
sudo apt-get install libavcodec-extra-53 libavdevice-extra-53 libavfilter-extra-2 libavformat-extra-53 libavutil-extra-51 libpostproc-extra-52 libswscale-extra-2

From memory I had to delete the kdenliverc file in ~/kde/share/config or somewhere there in the .kde folder sub folders and restart kdenlive, it will reset all settings to defaults though.

If you were talking to me about the crashing problem, I'm afraid I don't know where to go to find this ~/kde/share/config file. I found user>share>kde4>config but I don't see it there. I see other kdenlive files there but not "kdenliverc". I am so new to Ubuntu. Could you point me to that file??

Thanks...

The ~ references your home directory. The easiest way is probably to use the find file function from the Dolphin file manager.

@denean, no sorry it was to ronnberg, trying to find h264 encoding options.

And on crashing problems with kdenlive from svn I'm finding if I make any changes to the interface from the default, like closing the transitions, effects etc tabs and just having two monitors and the Project Tree, kdenlive from svn crashes repeatedly loading or playing media. Ubuntu Studio 64bit 11.10 xfce window manager, however not getting the problem on a different machine, Ubuntu 64bit 11.04 Gnome window manager. Very weird. :-(

I keep looking but I haven't found it...not sure what to do next.

I've double checked the path and it is in ~/kde/share/config but it's only created after finishing the kdenlive config process I think.

So for you the path may be /home/denean/kde/share/config/ and the file name kdenliverc

Are you using sunab's kdenlive svn build or stable 0.8 from Ubuntu's repositories?

Hi,

I'm using the stable release that DiveO mentioned above. But I am wondering if I should change to the svn build. Do you think that would help?

Thank you...

This is it!
Me funcionó muy bien y se me hizo muy fácil. También utilicé synaptic para introducir los repositorios. Que les sirva:

http://kubuntuforums.net/forums/index.php?topic=3118584.0

@denean Yes, sunabs svn solves the problem and gives you cutting edge kdenlive, albeit maybe a bit unstable at times.

Hi yellow. It worked :-) Since I just installed I haven't tried to do any editing yet, but it opens and plays my files.

Thank you and thanks to all in this thread who helped...much appreciated

Good to hear, kdenlive is becoming very enjoyable to use.

I also got the MLT error. I reinstalling with the other repositories. I was able to start Kdenlive go threw the wizard then it crashes. The program just closes.

Now what.

@evworld, have you tried locating and deleting the kdenliverc file mentioned in post #17 above?

yes I tried deleting the file and it didn't help. I really like Ubuntu and it is a shame that the upgrades just don't go smoothly.

yes I tried deleting the file and it didn't help. I really like Ubuntu and it is a shame that the upgrades just don't go smoothly.

You could try removing all traces of ffmpeg modules like libavcodec, libavformat etc and uninstall reinstall kdenlive or maybe first run the dbg version of kdenlive found in synaptic and or run kdenlive from a terminal to see what might be causing the error, I've found kdenlive stable on one machine unstable on another. Same versions of all.

Does kdenlive crash at start up or just when using the wizard?

I think I'm almost there. I now have 0.8.2 Kdenlive and I don't get that same error message anymore. However it's telling me as go thru the wizard that I need to upgrade from MLT 07.4 to 0.7.6 I downloaded the mlt-0.7.6.tar.gz file and now I have no idea what to do with it? Do I extract it to a folder? Which one. I hear others talking about a package manager and I have no idea what they mean as this version of Ubuntu 11.10 Oneinc doesn't have the Synaptic package Manager on it?

Do not use the tar.gz file, it is only the source code and requires a good linux knowledge to compile.
Process like this (in a terminal):

1) remove all MLT / Kdenlive packages:

sudo apt-get remove kdenlive libmlt* melt

2) make sure you have added the sunab repository:

sudo add-apt-repository ppa:sunab/kdenlive-release && sudo apt-get update

3) re-install kdenlive:

sudo apt-get install kdenlive

These 3 steps will install the latest Kdenlive / MLT packages from the sunab repository which is the recommanded way to install Kdenlive on ubuntu.

Hope it helps.

Thanks, sudo add-apt-repository ppa:sunab/kdenlive-svn worked a treat. SynapticPM not only sorted out the above problem, but as you'd expect, it also installed many missing codecs for rendering.

Hello
I did as in post 29 and was very happy to be able to start Kdenlive.

However each time I try to create a new project or open a file (file/new or File/open it crashes with the follwing message in the crash window with the following message : "Exécutable : kdenlive PID : 4844 Signal : Aborted (6)"

Any idea

This is a fully featured video editor for Linux, with timelines, effects, custom screens, ability to break detach audio from video.

If you are having problems installing due to an error in MLT module, do the following to install this properly (tested with Ubuntu Oneiric 11.10).

First open a new terminal and remove Kdenlive if you have installed it already:
sudo apt-get remove kdenlive

Now let's a personal package archive to Ubuntu from one of the developers of kdenlive (which contains the correct version of MLT):
sudo add-apt-repository ppa:sunab/kdenlive-svn

Next, lets get Ubuntu to fetch the latest distributions of the PPAs:
sudo apt-get update

Let's install those latest greatest package upgrades:
sudo apt-get dist-upgrade

Finally, lets install kdenlive (again):
sudo apt-get install kdenlive

And...now let's run it with "kdenlive"

Easy peasy when you know how, right? Enjoy this great video editor for Linux.