Ubuntu 7.10 issue

Got the latest KDENLIVE installed and all dependencies. When trying to capture from Sony DCR-TRV260 via firewire, I get the following error message.

Too many output file names.
Usage: dvgrab [options] [file] [-]
Try dvgrab --help for more information
pipe:: I/O error occured
Usually that means that input file is truncated and/or corrupted.

This device works fine with Kino but I wanted to try Kdenlive.

Thanks.

Which version of dvgrab is that ? Are you trying to capture dv or hdv ?

Same problem. I tried to capture standard pal DV, and dvgrab is the ubuntu gutsy version ( 3.0 )

Hi,

there's a known bug with dvgrab 3.0 and kdenlive, so you need to downgrade to dvgrab 2.1 to be able to capture files.

Best regards.
JM

Ok, thanks,
is there an ubuntu package somewhere ?

I am ready to be corrected, but I thought HDV support was only available with dvgrab 3.0 and not in dvgrab 2.1? Downgrading my dvgrab from 3.0 to 2.1 is a bit pointless as I need to capture HDV.

Any work arounds for this bug, besides downgrading dvgrab?

as an alternative you can use dvgrab from the command line and import the clips manually to kdenlive

If you have some experience compiling, you can also download and install the development version of dvgrab from cvs, it is compatible with Kdenlive. You will need to install all dependencies (libiec61883-dev, libraw1394-dev, libavc1394-dev, libdv-dev ) then:

cvs -d:pserver:anonymous@kino.cvs.sourceforge.net:/cvsroot/kino login
[press enter]
cvs -z3 -d:pserver:anonymous@kino.cvs.sourceforge.net:/cvsroot/kino co -P dvgrab

cd dvgrab
./bootstrap
make
sudo make install

regards

When I do this and try ./bootstrap this happens:

legendtofski@U-Booty:~/dvgrab$ ./bootstrap
./bootstrap: 2: autoreconf: not found
legendtofski@U-Booty:~/dvgrab$

What is missing?

Hi,

be sure you've installed the following packages

qt4-dev-tools, kdelibs4-dev, libsdl1.2-dev, libsdl-image1.2-dev, libsamplerate0, libsamplerate0-dev, libdv4-dev, ladspa-sdk, libjack-dev, swh-plugins, sox, sox-dev, libmad0-dev, subversion, libgsm1-dev, autotools-dev, g++, automake1.9, autoconf.

All of them can be found in Synaptic.

Then download last dvgrab version from cvs and follow compilation steps. It should work.

Best regards.
JM

Yes this worked, I think some of this info should be on the Wiki as many people seem to get the capture error and problems with running in sudo and files not having proper security/ownership!

I have discovered why dv capture was not working in Ubuntu/Kubuntu 7.10 (and possibly other versions). The user you are logged in as needs read/write permissions to /dev/raw1394. By default this is owned by root and in the group "disk". Add yourself to the group "disk" and capturing will work as expected.

I've read on the Wiki that the problems with dvgrab are solved upgrading to 3.1 version too.