Ubuntu Jaunty Jackalope (Alpha) - cannot save a project

19Mar09

I have a 24hour old Jaunty Jackalope installation.

I have managed to load the kdenlive software as described with

   sudo apt-get install kdenlive dvgrab frei0r swh-plugins libfaad0

and kdenlive seems to run fine. My project has one clip - an .ogv video file from  Examples/Ubuntu_Free_Fulture_Showcase which plays fine in the Clip Monitor and the Project Monitor. However, when I save the project as in the kdenlive folder under home as test.kdenlive, I get a crash with no project file being saved (SIGSEGV). I have tried running "sudo kdenlive" in case it was a permissions problem, but still get the same result.

Any help would be much appreciated.

My system is
Ubuntu release 9.04(jaunty)
Kernel 2.6.28-9 generic
Gnome 2.25.92

Memory 1002.4MIB
CPU Athlon64 Processor 3200+
Diskspace 31.2GB

Here is part of the details that come up in the dialog telling me that kdenlive has crashed:

kdenlive(5652) Render::stop: /////////////   RENDER STOPPED:  "project"
kdenlive(5652) Render::stop: /////////////   RENDER STOP2-------
kdenlive(5652) Render::stop: /////////////   RENDER STOP3-------
kdenlive(5652) Render::start: -----  STARTING MONITOR:  "clip"
kdenlive(5652) Render::start: -----  MONITOR:  "clip"  WAS STOPPED
kdenlive(5652) Render::start: -----  MONITOR:  "clip"  REFRESH
KCrash: Application 'kdenlive' crashing...
sock_file=/home/dick/.kde/socket-GWAYTOWER/kdeinit4__0
kdeinit4: preparing to launch /usr/lib/kde4/libexec/drkonqi

ndow::saveFileAs ()
#15 0x080cf9b0 in MainWindow::saveFile ()
#16 0x080df97f in MainWindow::qt_metacall ()
#17 0xb733fcb8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb73400f0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0xb6929951 in QAction::triggered () from /usr/lib/libQtGui.so.4
#20 0xb692aecf in QAction::activate () from /usr/lib/libQtGui.so.4
#21 0xb6dfa672 in QToolButton::nextCheckState () from /usr/lib/libQtGui.so.4
#22 0xb6d13023 in ?? () from /usr/lib/libQtGui.so.4
#23 0xb6d132f6 in QAbstractButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#24 0xb6dfab6c in QToolButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#25 0xb6986c03 in QWidget::event () from /usr/lib/libQtGui.so.4
#26 0xb6d112ae in QAbstractButton::event () from /usr/lib/libQtGui.so.4
#27 0xb6dfd59a in QToolButton::event () from /usr/lib/libQtGui.so.4
#28 0xb692ff5c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#29 0xb6938bd1 in QApplication::notify () from /usr/lib/libQtGui.so.4
#30 0xb7d0970d in KApplication::notify () from /usr/lib/libkdeui.so.5
#31 0xb7329a4b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#32 0xb6937c3e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#33 0xb69a7a3e in ?? () from /usr/lib/libQtGui.so.4
#34 0xb69a6d67 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#35 0xb69d1d2a in ?? () from /usr/lib/libQtGui.so.4
#36 0xb6083af8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb608705b in ?? () from /usr/lib/libglib-2.0.so.0
#38 0xb60871d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#39 0xb7355448 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#40 0xb69d1425 in ?? () from /usr/lib/libQtGui.so.4
#41 0xb732807a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#42 0xb73284ba in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#43 0xb732a969 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#44 0xb692fdd7 in QApplication::exec () from /usr/lib/libQtGui.so.4
#45 0x080c4f08 in main ()
#0  0xb7f6f430 in __kernel_vsyscall ()

 

Hi.

There was a bug in Kdenlive that caused a crash with Qt 4.5 on document saving. It was fixed in svn, so you can either try to compile the latest svn or wait for Kdenlive 0.7.3 which I hope to release somtimes in april.

regards

Hi j-b-m

Thanks for that - you have given me a good reason to finally find out how to compile an application from source. I will give it a go

hi

you can use kdenlive builder wizard, it does the compilation for you and it's more easy and you can install the soft where you want ...

 

give us news with jaunty, i will do the same ...

 

nyme

Got the same issue :( On Jaunty for a while now but only testing kdenlive now. Make ready for the fload of Jaunty posts coming :)

Allow me to be next to whine.  Kdenlive 0.7.2.1 does not save clips in Ubuntu 9.04 beta.  Took a while to figure out how to connect to the camera, too, but I posted that up on the Ubuntu bug reports.