Ubunut 12.10, Kdenlive 0.9.4, restricted extras installed but "Failed to create proxy clip"

So, like the subject says, I can't create proxy clips.
I had a previous version of kdenlive (whatever is latest canonical) on 11.10 then decided to update Ubutnu and kdenlive. Now I'm at 0.9.4 kdenlive and 12.10 ubuntu and things seemed to be fine, as they had been before only now with extra added goodness (and some pain due to having to fiddle with my dual screen setup to get Unity 3D working like 2D used to - got a compromise now but it's less good but that's an aside).

Up until now I hadn't been using proxy clips. his machine was doing a fine job with stuff from my Everio and Canon but today I wanted to cut some stuff from an iPhone and it stutters quite badly.

I turned on proxies and every video proxy fails. I installed the restricted extras, I even tried building them myself. In both cases I can create the proxy files manually using ffmpeg with the default proxy settings (no problems with libmp3lame etc) but it fails with kdenlive.

I remember another version of kdenlive would let you click on the error to get a log file of what went wrong but not this version. I cannot figure out how to find out what went wrong. Clip properties claims there is a 0 byte proxy file but there is no such file in the proxy directory that I can see.

Any sugestions? How can I find out what's going wrong.

Try creating a custom proxy preset for the project under Settings -> Config Kdenlive -> Project Defaults.

Can you render a project from 0.9.4 or does that fail too?

If it is an issue with ffmpeg version, you can download daily builds from here and try: http://builds.meltytech.com/kdenlive/latest.rss


MPEG2 was no probelm but when I tried to render MPEG4 I got an error that there was no libmp3lame, which is odd because I know that my ffmpeg definately has libmp3lame.

Then I remembered I had read somewhere that running the "Settings->Run Config Wizard" again can help since I had installed the extras after installing and running kdenlive.

Now I can render and the proxy clips are working as they should. Thanks for the clue. :) It would probably have taken me a long time to find that since I generally have been rendering to MPEG2 these days.