unable to load debian binaries after upgrade to lenny

I upgraded my system to lenny and using synaptic to get and install kdenlive returns dependancy errors mostly involving mlt and its subsidiaries. The offending files are in the repository so I'm not clear why apt doesn't just get them too. I suspect it is a deeper dependancy issue, because if I try to get and install them they blow with even more dependancy issues. I am not able to load the deb src multimedia lenny main repositories. It gives this error:

 

W: GPG error: http://www.debian-multimedia.org lenny Release: Unknown error executing gpgv

 

Any help would be appreciated

 

Mark

What is your /etc/apt/sources.list file?

Mine is:

# Security
deb-src http://security.debian.org/ etch/updates main contrib
deb http://security.debian.org/ etch/updates main contrib

# Line commented out by installer because it failed to verify:
deb-src http://ftp.fr.debian.org/debian/ unstable main contrib non-free
deb http://ftp.fr.debian.org/debian/ unstable main contrib non-free

deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free

deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free

# Multimedia
deb http://www.debian-multimedia.org experimental main
deb-src http://www.debian-multimedia.org experimental main

deb http://www.debian-multimedia.org sid main
deb-src http://www.debian-multimedia.org sid main

deb http://www.debian-multimedia.org testing main
deb-src http://www.debian-multimedia.org testing main
 

Then set the default stage to unstable in /etc/apt/apt.conf:

APT::Default-Release "unstable";
APT::Cache-Limit 100000000;
 

Then type:

apt-get update

apt-get dist-upgrade

apt-get install kdenlive

Thanks for getting back about this. Changing the repos didn't work and I tried quite a few different options. It was suggested to me that I try using aptitude instead of apt and with only the deb multimedia lenny main repo active it worked like a charm. The depth of dependancy issues I encountered may be something about the new mepis distro I'm using but this aptitude program is the real deal.

 

Thanks again,

Mark