Unsupported Codecs... highly frustrated please help!

So I just installed Linux/Ubuntu last night for the first time. I really wanted to try out some open-source video editors on here.

Anyways, pitivi is seriously lacking so I checked out KDEnlive.

Well, I'm frustrated.

I spent about 7 hours today trying to set it up, going through pages and pages of tutorials to no avail. It says unsupported codecs on MPEG-4, H.264, Flash, and XVid.

I looked and I have all the necessary codecs installed, I even went through manually installing all dependencies for it, and I am positive they're all installed. I just don't understand.

I'm super pissed because I wasted a whole day on this and nothing has improved. I even went through this whole page here: http://ubuntuforums.org/showthread.php?t=786095.

*sigh* I guess a open-source video editor truly was to good to be true. This sucks.

have you installed ubuntu-restricted-extras?

I installed that package and kdenlive and every codec is then installed for me, never had a problem with any video file

Would also be worth activating the medibuntu repository, which has even more stuff in it http://medibuntu.org/

Perhaps it would help if you knew what exactly you need. Just a list of supported codecs or you want to actually use the one that you need?

I've tried video editors on 3 different platforms (win, lin, mac) and found Kdenlive on top of all (my personal preference). It lacks minor details but I'm sure they'll be added through time.

Ok well I tried the Ubunutu-Unrestricted-Extras, that didn't do anything.

I don't know what I need to get, it just says for example on h.264 "Unsupported video codec: libx264".

The others that have unsupported codecs are audio. I just don't understand because I've downloaded every h.264 codec there is and tried to create a profile using different ones and they all say unsupported.

What's the output of these commands:
melt -query video_codecs
ffmpeg -codecs
ls -l /usr/lib/libmlt* /usr/local/lib/libmlt*

It looks like you do have the right codecs installed. The only thing I can suggest is running kdenlive's Config Wizard again. You will find it under the Settings menu.

That did absolutely nothing, I've tried that about a dozen times. *Sigh*

When you run the Config Wizard on kdenlive, does it report any modules as missing?

I noticed you are using a more recent version of ffmpeg than I do. Perhaps you could try using an older version just to see if it makes a difference. This is what I have installed right now:

FFmpeg version SVN-r26402, Copyright (c) 2000-2011 the FFmpeg developers
built on Jun 1 2011 13:37:28 with gcc 4.4.5
configuration: --prefix=/usr/local --enable-shared --enable-pthreads --disable-stripping --enable-version3 --enable-gpl --enable-nonfree --enable-postproc --enable-x11grab --enable-libfaac --enable-libgsm --enable-libmp3lame --enable-libvpx --enable-libx264 --enable-frei0r
libavutil 50.36. 0 / 50.36. 0
libavcore 0.16. 1 / 0.16. 1
libavcodec 52.108. 0 / 52.108. 0
libavformat 52.93. 0 / 52.93. 0
libavdevice 52. 2. 3 / 52. 2. 3
libavfilter 1.74. 0 / 1.74. 0
libswscale 0.12. 0 / 0.12. 0
libpostproc 51. 2. 0 / 51. 2. 0

Hey Zorphon -

I found this thread because I was having the exact problem you were. What made it worse, is that I had had Kdenlive earlier on in another install of Ubuntu, but now, when I had recently reinstalled, the bastard would not work.

What made mine work was following the advice above. In fact, my video is finishing rendering now, so I know at least that part works.

Rather than restate what someone up there said, let me post some links -

1) Go to this page ------>http://medibuntu.org/repository.php

2) Open your terminal and copy/paste the first line they give you there. In fact let me copy past it here -

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

3) It will ask for your password, but after you post that in it should start working.

4) Go into your software center and in the search bar type "codecs" . The very first option that pops up is called "Non-free codecs". Install it.

That was it for me. After that I was all home free. I hope it works for you - nothing pisses me off more than computer problems.

Cheers,
M

Other posibility: instead of medibuntu, simply try to install libav-extra-5x, that is, the most recent for your distro. You may need to convince your installer to really install. Next, check your kdenliverc that it lists the codecs ... you will need to delete it in order to let kdenlive scan for codecs and recreating the file. There's another thread on this.