Using threads=0 or threads=4 in profile doesn't utilize extra cores

Hi,

Firstly I am blown away by how far Kdenlive has come after being away from it for over a year! I develop AV Linux which is an LXDE based Debian Multimedia Content Creation distro which features the well known gtk based Linux NLEs LiVES and Openshot as well as Cinelerra. I originally included Kdenlive but it was difficult to integrate into LXDE without font display issues not to mention the added bulk of the KDE4 support libs. Recently I did an experiment with a KDE4 based AV Linux and finally got re-acquainted with Kdenlive and am very impressed with 0.7.8.

One issue I've encountered is trying to get profiles to use all the threads for rendering on a quad core machine, Handbrake and WinFF will use all the cores but not Kdenlive. I have created a custom x264 profile for my iPod and passing the 'threads=0' or 'threads=4' command doesn't seem to make any difference to the encoding speed even if I use existing Kdenlive x264 profiles. I am using mlt 0.5.10, ffmpeg 0.6SVN-r24504 and libx264-104 on Debian Squeeze.

Here is the profile:

s=640x480 aspect=%dar progressive=1 threads=4 acodec=aac ab=128k vcodec=libx264 crf=21 flags=+loop cmp=+chroma partitions=+parti8x8+parti4x4+partp8x8+partb8x8 me_method=umh subq=5 me_range=16 g=250 keyint_min=25 sc_threshold=40 i_qfactor=0.71 qcomp=0.6 directpred=1 trellis=1 coder=0 bf=0 refs=1 flags2=-wpred-dct8x8 level=13 bufsize=768k wpredp=0 bt=256k

Any help would be appreciated...

Forums:

Hmm... I'm not sure but check this out:
Are your other options for x264 ok? I found out, that ffmpeg/x264 will fall back to a default option set, when there only one nonsense option is present. You cannot see this, when kdenlive is rendering.
Try to render your project file direct with melt -verbose and check the console output, if there are libx264 warnings present.
I had a similar problem.
Here is a solved thread from me how to render with verbose settings direct from the console.

http://kdenlive.org/forum/solved-how-render-only-part-project-direct-melt
I've also used this to find good and working x264 codec settings.

Hi,

Thanks for the reply, I'll check it out with -verbose. Sometimes I wish the x264 devs would go on vacation for a while! It has been broken, fixed, partially broken with mlt many times now....

p.s. instead of specifying all those video encoding specific options, melt does support the vpre option. Set it to the full path of a ffmpeg x264 preset file. I will retest the threads option soon.