Video codec libx264 is not supported (Solved)

When I try to render project in H.264 codec, Kdenlive informs that "video codec libx264 is not supported".
Kdenlive is version 0.8.2.1 and platform 4.6.5. MLT is 0.7.6.
Ubuntu 11.04 (Natty).

I also used "sudo apt-get install libavcodec-extra-52 libavdevice-extra-52 libavfilter-extra-1 libavformat-extra-52 libavutil-extra-50 libpostproc-extra-51 libswscale-extra-0" what was a succesfull command in version 0.8 to get x264 codec to work out.

How can I get x264 supported?

Forums:

This has happened to me and there are other threads with similar issues. What worked for me was to remove the kdenliverc file from within your home directory at ~/.kde/share/config.

If that doesn't do it there are other threads, which may solve it for you.

Yes! That solve the problem. (There really wass treads with same issue but I was too afraid to do someting that kind with the terminal.)
I have installed Kdenlive several times in three computers, but this was first time when this kind of matter happened. Annoying issue even it's so easy to solve. (if you now what to do ;-) )
Thanks a lot yellow.

I have this problem as well. I have just updated to Ubuntu 11.10 and at first Kdenlive did not support libfaac anymore. Then I have uninstalled ffmpeg and reinstalled everything like it is explained here to no avail.
Kdenlive (versione 0.8.3) keeps reporting that many codecs are missing; libx264, libxvid, libmp3lame. I have tried following the instructions here, including deleting kdenliverc
I have installed the medibuntu repositories.

I have read these guides

http://ubuntuforums.org/showthread.php?t=1117283

http://andnovar.wordpress.com/2011/08/23/installing-libx264-and-ffmpeg-o...

At this point I'm giving up, waiting for the next release of ubuntu. As a last attempt, I would like to know if there is a way to manually tell kdenlive (or ffmpeg) where to look for the missing codecs (like specifying the path).
Thanks

Mediabuntu repos are unnecessary and could cause conflicts, Ubuntu's own repos have everything that's needed apart from bang upto date kdenlive/MLT/Frei0r such as available from sunabs svn/git or stable PPA.

You could try aiming to clean out all old ffmpeg/libav files to remove any incompatibilities by removing kdenlive, etc, all the ffmpeg/libav stuff like libavformat, libswscale, etc via synaptic, make sure you get them all, then remove mediabuntu repo's from sources list, reload source list in synaptic, then go into the various locations libav resides like /usr/lib and remove any libav libraries that might be left from previous builds / sources.

Then if you haven't already, add sunabs svn/git or stable PPA and reinstall kdenlive etc.

Delete the kdenliverc file if it's been recreated and see if that helps.

Thank-you very much. At the end of the day, I decided to remove everything as you said, than I upgraded to ubuntu 12.04 and reinstalled kdenlive.
Now it finds libx264 but not libfaac even if it is installed.
So I have tried changing a profile, from acodec=libfaac to acodec=aac.
Till now it does not work (video ok, no audio).
I have libavcodec-extra-53.

I am having a similar problem with ubuntu 12.04 64bit.

I can't seem to export into any reasonable format:

MPEG-4 - Unsupported audio codec: libmp3lame
Xvid4 - Unsupported audio codec: libxvid
H.264 - Unsupported audio codec: libx264

I have all of those programs installed. I have removed kdenliverc and I have re-installed kdenlive. Is there something I'm missing?

Thanks in advance.

I've held off upgrading to 12.04 for the time being as always with distro updates vs apps catching up. But what version of kdenlive are you using? Have you enabled all the repos in synaptic for restricted libraries like aac ie: multiverse?

You just led me to the answer, thank you! I guess I was missing a gstreamer plugin. I would have thought that was installed with Ubuntu restricted extras, but I guess not.

To answer your question, I'm using kdenlive 0.8.2.1.

Thanks again!