Won't compile

Nevermind, fixed it.

Make went up to 107%, btw.

ffs

Fatal Error: MLT's avformat (FFMPEG) module could not be found.

EDIT: It's working now. The reason it didn't was that i had not installed FFmpeg from source. I installed it with apt-get. After removing the apt-get packages I compiled and installed from source - everything worked after that.

My MLT isn't compiling either. How do I solve this?

$ make clean;make
...
cc -shared -o ../libmltavformat.so factory.o producer_avformat.o consumer_avformat.o filter_avcolour_space.o filter_avresample.o filter_avdeinterlace.o -lavformat -lavcodec -ltheora -lvorbisenc -lraw1394 -lavutil -lvorbis -lm -logg   -L../../framework -lavformat -lavcodec -lavutil -lavdevice  -lmlt -lswscale
/usr/bin/ld: cannot find -lavdevice
collect2: ld returned 1 exit status
make[2]: *** [../libmltavformat.so] Error 1
make[2]: Leaving directory `/home/bjn/video/mlt/mlt/src/modules/avformat'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/bjn/video/mlt/mlt/src/modules'
make: *** [all] Error 1

configuration looked like this:

$ ./configure --prefix=/usr --enable-gpl --qimage-libdir=/usr/lib/ --qimage-includedir=/usr/include/qt4 --avformat-swscale
Configuring framework:
Configuring modules:
Configuring modules/avformat:
Configuring modules/core:
Configuring modules/dgraft:
Configuring modules/dv:
Configuring modules/effectv:
Configuring modules/feeds:
Configuring modules/fezzik:
Configuring modules/frei0r:
Configuring modules/gtk2:
Configuring modules/inigo:
Configuring modules/jackrack:
Configuring modules/kdenlive:
Configuring modules/kino:
Configuring modules/lumas:
Configuring modules/motion_est:
Configuring modules/normalize:
Configuring modules/oldfilm:
Configuring modules/plus:
Configuring modules/qimage:
Qt version 4.x detected, will compile Qt4 qimage producer
Include directory:  /usr/include/qt4
Configuring modules/resample:
Configuring modules/sdl:
Configuring modules/sox:
Configuring modules/valerie:
Configuring modules/vmfx:
Configuring modules/vorbis:
Configuring modules/westley:
Configuring modules/xine:
Configuring inigo:
Configuring valerie:
Configuring miracle:
GPL License Used

I am not sure how to solve your compilation problem, but you could try building using the Wizard at http://tinyurl.com/kbw070.

Regards

Mads

In my edit i tried to explain that I got it to compile. Took my about 6 hours of in total from a clean ubuntu installation. Didn't know there was a script that did it for me. Thank you.