Works on 0.8.3 Error on 0.9.3 Missing clip when adding project file as a clip Invalid

Howdy,
I edit a local half hour TV show and like to compile subprojects saved as KdenLive projects.
I then later put them into the shows as time allows to meet the time limitations.
I do not want to stop and render nor lose any quality.

This worked fine in 0.8.3 but does not now in 0.9.2.
I can see the clip (project loaded as clip ) and play it on the timeline
but the actual clip does not render and indicates invalid on the rendered file playback.

I tested the project that would not work in 0.9.2 and it works fine in 0.8.3.
I also tried several other projects like this and they all fail in 0.9.3.

Any thoughts specifically on this or how I could go about troubleshooting it ?

Or if anybody has other ideas on how to do this without rendering to create and package sub projects for later compilation without quality loss please let me know.

This is a very important feature to me. This working and audio scrub would make KDEnlive the perfect editor for what is already very good.

Thanks for your time and consideration.
Ross

Forums:

I have just checked, and there is a bug report in mantis for a similar issue to this:-

http://www.kdenlive.org/mantis/view.php?id=2755

Have a look, and if it's similar, confirm the problem.

Hi Norm,
You are right that is the bug there.
That sounds like it.
It is also interesting that picked up as Intel (the machine I am using for 0.9.2)
I still have 0.8.3 on an AMD machine and thought it was the version not the processor.
I will try an update on the AMD machine and confirm it later.

Thanks,
Ross

More details.
I tested no difference AMD vs Intel.
The bug is still there on an AMD using V 0.9.3

I did notice 0.9.2 has a supported types on clips when invoking the load window
and does not list projects.When I load I am picking the unsupported types.
PLEASE WE NEED PROJECT LEVEL (really subprojects) support.

Version 0.8.3 on supported types lists and loads and works
fine with project files.

Version 0.8.3 also seems backwards compatible in loading 9.9.2 projects
and using them as clips no problems.

My guess is that it is something in how version 0.9.2 expects the clip to be loaded with some data.

I believe I changed the director on one Kdenlive project file and succeded in getting it to play in the clip monitor (loaded as a clip)
but never in the project monitor ( invlalid).

Does anyone know the details of the project file structure and what data is required upon clip load in 0.9.2 vs 0.8.3 ?

I looked for reference documents and could not find relevant information.

Ross

WOW, THAT WAS FAST.
Seems to be working now on the development version (with a simple test - will test further).
It is not too easy to install it, but seems worth it.

Thanks,
Ross

Hi Ross,

Glad things are looking up. When I saw your post yesterday, I tried it out, and it worked fine for me, but I am using the latest from sunab's ppa, (kdenlive-svn +MLT-git BEWARE! Testing only!). As it says, this is for testing of the latest additions and bug fixes which can, and sometimes do, go wrong. Not that often though. This is geared mainly to Ubuntu and comes down as updates to the Update Manager.

Saying that, I always keep a few buildscript copies tucked away for times of peril. Being completely independent from my main installation, they are brilliant and always there as a fall-back. Just running the buildscript gives me the latest copy all done in 5 minutes without overwriting any previous versions. The only draw back is they don't seem to have XVid4 support and sometimes I need .avi files.