Wrong aspect ratio in project monitor and rendered files

Hi all,

I have a strange problem.
I am busy editing a kdenlive project with MPEG files from a JVC Everio SD camcorder.

When I import the video files they appear as 4:3 video. I can correct this by setting the 'force aspect ratio' to 1.42 for each clip. Playing back the clip in the clip monitor then is OK: it is displayed as 16:9. Also when I use the clips in the timeline, it is displayed as 16:9 in the project monitor.

But after a while the clips get played back as 4:3. The way this happens is as follows:
- When I play all through the project from the beginning, the video in the project monitor is displayed as 16:9. At a certain time in the timeline, at the beginning of a new clip, it 'jumps' to 4:3 in the project monitor.
- After this moment, everything (even before and after this clip in the timeline) is played back as 4:3.
- When I check the 'force aspect ratio' all clips are set to 1.42
- When I retry to set the 'force aspect ratio' (change it to 1.43 and then back to 1.42), some clips don't get played anymore in the project monitor, but they *can* be played via the clip monitor.

When I restart kdenlive, reload the project, all seems to be OK, but when I play back the whole project, at the same clip the problem just reappears.

The same results when I render the project to a file, at the same clip, the video is sqeezed back to 4:3 for the rest of the movie.

I ran into this issue editing a 30 minute movie and would like not to have to start all over again, so I hope maybe someone has a fix. I am running kdenlive 0.7.8 on an ubuntu 9.10, mlt version is 0.5.10

Has anyone got a clue?

Thanks in advance!

Jurgen.

Forums:

Hi, but you set the project first?

If you don't set to 16:9 the entire project, after the render not works like you want.

Hi Jurgen,

I don't know why kdenlive forgets it's aspect ratio settings, but I have found another solution:

I own a JVC Everio too and I figured out, that the aspect ratio flag in the MOD file isn't set. So I wrote a small command line program which makes a copy of the MOD file with the aspect ratio flag corrected according to information in the MOI file.

You can download it here: http://www.castelli-group.net/useful/modder

Just execute it without parameters to see how it has to be used

greetz, Dets ...

Hi Lorenzo and Dets,

Thanks for your posts!

@Lorenzo: My project is a DV/DVD Widescreen PAL project, so I assume that must be correct
@Detz: Thanks for your tool! I hope that I can replace the current MOD files with the ones corrected by your tool without losing all edits in the project. I will try it and come back to you.

Thanks,
Jurgen.

Hi Detz,

I tried 'modder' and it works well, but unfortunately it does not solve the aspect ratio problem in my current project.

I converted clips with the 'modder' tool and re-inserted the clips in the current project. That seemed to go well, but the problem still appears at the same clips when I play back the project.

When I create a new project with the same clips, the aspect ratio is fine. So, for future projects I will certainly use modder!

After the comparison of the two project files (my problematic project file and a newly created), it seems to be that the 'corrupt' one uses a comma a decimal separator, as the new project file uses a dot as a decimal separator. Maybe that is the cause. I will search the bugtracker if this is already a known bug.

I finally discovered that the cause of this problem must have been in some kind of corruption of the project file. I think that the 'timeline entries' of clips in the project were corrupted.

I solved the problem by removing the problematic clips from the project tree and also from the timeline. After that I added the clips again and put them again in the timeline. Now everything plays back and renders fine.

I downloaded "modder" but do not understand how to run it, I get an error message box with "Could not display "/home/gregor/Videos/DeprPPSamtal/modder. There is no application for executable files"
(Running Ubuntu 10.04)

@Dets, thank you very much for modder! It worked perfectly :)

@clockworkpc: Nice to hear that you like it :-)

Dets ...