X crash on kdenlive start

Hello all,
I started kdenlive for the first time, I made a new slide show project, exported correctly and then after few clicks (I don't remember what I was trying) X got a weird crash with a window full of € (I know I need money thanks to kdenlive to remind this:)
After this each time I start kdenlive X crash, no matter I delete the project dir.
If I start from the terminal redirecting error this is the output:
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
: Fatal IO error 2 (File o directory non esistente) on X server :0.0.

kdm.log is a little more verbose...

6 XSELINUXs still allocated at reset
SCREEN: 0 objects of 232 bytes = 0 total bytes 0 private allocs
DEVICE: 0 objects of 32 bytes = 0 total bytes 0 private allocs
CLIENT: 0 objects of 224 bytes = 0 total bytes 0 private allocs
WINDOW: 0 objects of 64 bytes = 0 total bytes 0 private allocs
PIXMAP: 3 objects of 136 bytes = 408 total bytes 0 private allocs
GC: 0 objects of 72 bytes = 0 total bytes 0 private allocs
CURSOR: 1 objects of 8 bytes = 8 total bytes 0 private allocs
CURSOR_BITS: 1 objects of 8 bytes = 8 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 5 objects, 424 bytes, 0 allocs
3 PIXMAPs still allocated at reset
PIXMAP: 3 objects of 136 bytes = 408 total bytes 0 private allocs
GC: 0 objects of 72 bytes = 0 total bytes 0 private allocs
CURSOR: 1 objects of 8 bytes = 8 total bytes 0 private allocs
CURSOR_BITS: 1 objects of 8 bytes = 8 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 5 objects, 424 bytes, 0 allocs
1 CURSORs still allocated at reset
CURSOR: 1 objects of 8 bytes = 8 total bytes 0 private allocs
CURSOR_BITS: 1 objects of 8 bytes = 8 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 2 objects, 16 bytes, 0 allocs
1 CURSOR_BITSs still allocated at reset
CURSOR_BITS: 1 objects of 8 bytes = 8 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 1 objects, 8 bytes, 0 allocs
2 PICTUREs still allocated at reset
TOTAL: 0 objects, 0 bytes, 0 allocs
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: File o directory non esistente
QFileSystemWatcher: failed to add paths: /tmp/1449288905/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
kdmgreet: Fatal IO error: client killed

X.Org X Server 1.9.0
Release Date: 2010-08-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
Current Operating System: Linux studio 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-27-generic root=UUID=9d4fb0cd-1e27-4a42-a34f-5df59f377b8d ro quiet splash
Build Date: 09 January 2011 12:14:27PM
xorg-server 2:1.9.0-0ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.18.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 14 11:13:16 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: File o directory non esistente
QFileSystemWatcher: failed to add paths: /tmp/1402517661/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
ddxSigGiveUp: Closing log

X.Org X Server 1.9.0
Release Date: 2010-08-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
Current Operating System: Linux studio 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-27-generic root=UUID=9d4fb0cd-1e27-4a42-a34f-5df59f377b8d ro quiet splash
Build Date: 09 January 2011 12:14:27PM
xorg-server 2:1.9.0-0ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.18.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 14 13:51:11 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: File o directory non esistente
QFileSystemWatcher: failed to add paths: /tmp/0384655576/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
ddxSigGiveUp: Closing log

stock kdenlive 0.7.7.1+svn4571-1 on ubuntu 10.10
I have
libmlt++3 0.5.6+git20100727-1
libmlt2 0.5.6+git20100727-1
don't know if this is the problem... if that is the case there is a packaging problem...

any advice? thanks in advance

Forums:

In a terminal window, does 'melt noise:' (note the colon) play without crashing X?

hello ddennedy, sorry for the long delay, I confirm that 'melt noise:' works without problems and I can see like my disconnected tv without X crashing.
How can I reset the situation? I've been able to use kdenlive up to exporting my very first work...:)
Moreover if I switch user kdenlive starts without problems. I think is because it tries to recover the session that caused the problem.
So how can I reset the session? I got rid of the kdenlive directory that were setup during the wizard on the first run, but that is not enough apparently...
thanks in advance

I solved ripping ~/.kdenlive directory and ~/.kde/share/config/kdenliverc I don't know which did the trick but luckily it restarted presenting the wizard and after that it started normally.
I will keep up this post if I find what actually triggers this anomaly
Eli